月度归档:2019年02月

PHP 编译安装详解

前段时间,想尝试下 PHP 的多线程扩展 pthreads,由于其要求 PHP 启用 ZTS (Zend Thread Safety),
但是笔者所使用的发行版所能安装的 PHP 包都是 non-zts 的,所以只能自行编译和安装 PHP 了。

题外话,貌似基本大多数 Linux 发行版的 PHP 包都是 non-zts 的,比如 Ubuntu、CentOS、Arch Linux 等。
不过据我所知,Arch Linux AUR 有 ZTS 版本的 PHP,传送门可在本文底部相关链接找到。
另外 Gentoo 的话,PHP 默认是 ZTS 的。

[……]

继续阅读